kegen.bat fails to crearte pem file

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

kegen.bat fails to crearte pem file

I am a new user to Shibboleth
I Installed shibboleth-sp-2.5.2-win64.

I am need to run keygen.bat and generate new pem files.

My host DNS name fro the server is

When I run ..
keygen.bat -f -h -y 2

I get..
WARNING: can't open config file: /usr/local/ssl/openssl.cnf
Loading 'screen' into random state - done
Generating a 2048 bit RSA private key
writing new private key to 'E:\shibboleth-sp\etc\shibboleth\sp-key.pem'
problems making Certificate Request
4072:error:0D07A07C:asn1 encoding routines:ASN1_mbstring_ncopy:illegal character

I see a new sp-key.pem file is created but no sp-sert.pem file.

I inserted the IP address instead of in the command and ran it,,and get both pem files.

Is it ok to use the Ip address?

I was told to remove the _ underscores from the host name and it would work.
I tried it and sure enough, the pem files are creted.
However, doesn’t removing the _ underscore from the host name make the name invalid in the
 pem file?