ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1

krzyspiak
Hi,

I am using IIS5 on a W2k server. Shibboleth installation v2.3.1 went
through fine, however the Shibboleth ISAPI filter shows a red arrow
with an Unknown priority and that it was not loaded. Tried adding
this filter also directly to the default website as well as the
direct website shibboleth is to be used on. The shibd.exe -check says
the configuration is loadable. Neither the shibd.log or native.log
show anything menacing as far as can be seen. The shibboleth install
directory has full control to everyone. Also tried "tickling" the
site by going to it locally through localhost or from the outside
which supposefly sometimes loads the filter and this did not make a difference.

The Event Viewer has one added bit of info:
The description for Event ID ( 7701 ) in Source ( Shibboleth ISAPI
Filter ) cannot be found. The local computer may not have the
necessary registry information or message DLL files to display
messages from a remote computer. The following information is part of
the event: Filter shut down...

and

The description for Event ID ( 2100 ) in Source ( Shibboleth ISAPI
Filter ) cannot be found. The local computer may not have the
necessary registry information or message DLL files to display
messages from a remote computer. The following information is part of
the event: Filter failed to generate a random anti-spoofing key (if
this is Windows 2000 set one manually)..

Maybe this is a common issue, but I did try looking around for this
problem and did play around with poking around with some different
settings. The current state is clean now, and I am not sure where to
try from here. Any help or suggestions would be very much appreciated.

Thank you.

Rob

Reply | Threaded
Open this post in threaded view
|

Re: ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1

Peter Schober
* Robert D. Krzyspiak <[hidden email]> [2010-08-26 16:37]:
> The following information is part of the event: Filter failed to
> generate a random anti-spoofing key (if this is Windows 2000 set one
> manually)..

https://spaces.internet2.edu/display/SHIB2/NativeSPSpoofChecking
-peter
Reply | Threaded
Open this post in threaded view
|

RE: ISAPI filter not loaded using IIS5 and Shibboleth v2.3.1

Cantor, Scott E.
In reply to this post by krzyspiak
> The description for Event ID ( 2100 ) in Source ( Shibboleth ISAPI
> Filter ) cannot be found. The local computer may not have the
> necessary registry information or message DLL files to display
> messages from a remote computer. The following information is part of
> the event: Filter failed to generate a random anti-spoofing key (if
> this is Windows 2000 set one manually)..

https://spaces.internet2.edu/display/SHIB2/NativeSPSpoofChecking

https://spaces.internet2.edu/display/SHIB2/NativeSPInProcess

-- Scott