requested url not found on the server

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

requested url not found on the server

mahesh.softbrain
Hi,

I have setup shibboleth idp,sp as specified in the instructions.
http://localhost/idp/profile/status returns ok.

https://localhost/secure is redirecting to https://idp.mahesh.com/idp/profile/SAML2/Redirect/SSO?SAMLRequest=fZHNTsMwEIRfJfK9sUlpRawmUmgPVCo0agIHLsixt8QisYPX4eftSZsilQM9%0Arjzz7c54gaJtOp71vjY7eO8BffDVNgb58SEhvTPcCtTIjWgBuZe8yO43PAoZ%0A75z1VtqGBBkiOK%2BtWVqDfQuuAPehJTzuNgmpve%2BQU6pVF7aiBqxDaVta1Lqq%0AbAO%2BDhEtPVAjmm%2BLkgSr4QxtxAH4r30Y6XDAXjdw8u5AaQfS06LYkmC9SsiL%0AmMWy2st5pJhQ%2B2uppgpYJVTMFItnN3KQIfawNuiF8QmJGIsnbD65isuI8dmM%0AT%2BfPJMhPOW%2B1Udq8Xi6lGkXI78oyn4x5nsDhMcsgIOniUC0%2FLnZnZV%2FGit%2BG%0ASdqKtyJf0DPKiOz4w2Bbr3LbaPkdZE1jP5cOhIeEXBGajpa%2Fn53%2BAA%3D%3D%0A&RelayState=cookie%3Abe188467

and I am getting a 404 error.
Not Found
The requested URL /idp/profile/SAML2/Redirect/SSO was not found on this server.

However, I can see the saml request in the shibd.log

<samlp:AuthnRequest xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" AssertionConsumerServiceURL="https://idp.mahesh.com/Shibboleth.sso/SAML2/POST" Destination="https://idp.mahesh.com/idp/profile/SAML2/Redirect/SSO" ID="_a59cbfc62d0adf4cd3de0bad90d0958c" IssueInstant="2009-06-19T20:55:36Z" ProtocolBinding="urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST" Version="2.0"><saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion">makSP</saml:Issuer><samlp:NameIDPolicy AllowCreate="1"/></samlp:AuthnRequest>


Im also seeing "File does not exist: C:/Apache2.2/htdocs/idp" in error.log in apache.
I have configured the vhosts, jk mount etc..

Could you please throw some light as googling is not leading me any where.

Thanks
Mahesh
Reply | Threaded
Open this post in threaded view
|

RE: requested url not found on the server

Cantor, Scott E.
> Im also seeing "File does not exist: C:/Apache2.2/htdocs/idp" in error.log
> in apache.
> I have configured the vhosts, jk mount etc..

But not correctly. This isn't about Shibboleth, you need to get Apache and
Tomcat integrated and working, or skip the Apache part and use Tomcat by
itself as the web server.

You should probably be using mod_proxy_ajp, and there are no JKMount
commands anymore with that, that uses ProxyPass settings using the ajp:
scheme.

> Could you please throw some light as googling is not leading me any where.

Try the Tomcat list?

-- Scott


Reply | Threaded
Open this post in threaded view
|

Re: requested url not found on the server

mahesh.softbrain
In reply to this post by mahesh.softbrain
Hi Scott,

Thanks a lot for the insight. As you have suggested, my httpd.conf was messy with Alias, jk mount etc. I cleared out every thing and added mod proxy ajp and it worked just fine.

Thanks
Mahesh


On Fri, Jun 19, 2009 at 8:37 PM, Scott Cantor <[hidden email]> wrote:
> Im also seeing "File does not exist: C:/Apache2.2/htdocs/idp" in error.log
> in apache.
> I have configured the vhosts, jk mount etc..

But not correctly. This isn't about Shibboleth, you need to get Apache and
Tomcat integrated and working, or skip the Apache part and use Tomcat by
itself as the web server.

You should probably be using mod_proxy_ajp, and there are no JKMount
commands anymore with that, that uses ProxyPass settings using the ajp:
scheme.

> Could you please throw some light as googling is not leading me any where.

Try the Tomcat list?

-- Scott