Uncaught Exception A software error was encountered that prevents normal operation

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Uncaught Exception A software error was encountered that prevents normal operation

Alexandre Adao
Hello,  I am a novice on shibboleth. I am running on Windows Server 2016 Standard. I have completed successfully the install and created the Metadata.  I configured the TestShib with no issues. However, when I actually do the test. I have the following error"

Web Login Service - Uncaught Exception
A software error was encountered that prevents normal operation:

org.springframework.webflow.definition.registry.FlowDefinitionConstructionException: An exception occurred constructing the flow 'authn/Password'

Please report this problem to your Help Desk or administrative staff. It has also been logged for an administrator to review.

This is what is shown on my idp-process.log, How can set the Debug to see more details on shibboleth?

18-04-26 17:53:35,297 - ERROR [net.shibboleth.idp.authn:-2] - Uncaught runtime exception
org.springframework.webflow.definition.registry.FlowDefinitionConstructionException: An exception occurred constructing the flow 'authn/Password'
at org.springframework.webflow.engine.builder.DefaultFlowHolder.assembleFlow(DefaultFlowHolder.java:111)
Caused by: org.springframework.webflow.engine.builder.FlowBuilderException: Unable to get the model for this flow
at org.springframework.webflow.engine.builder.model.FlowModelFlowBuilder.doInit(FlowModelFlowBuilder.java:154)
Caused by: org.springframework.webflow.engine.model.builder.FlowModelBuilderException: Unable to find flow 'authn/conditions' to inherit from
at org.springframework.webflow.engine.model.builder.xml.XmlFlowModelBuilder.mergeFlows(XmlFlowModelBuilder.java:646)
Caused by: org.springframework.webflow.engine.model.registry.NoSuchFlowModelException: No flow model 'authn/conditions' found
at org.springframework.webflow.engine.model.registry.FlowModelRegistryImpl.getLocalFlowModelHolder(FlowModelRegistryImpl.java:94)
2018-04-26 17:53:35,297 - WARN [org.opensaml.profile.action.impl.LogEvent:105] - A non-proceed event occurred while processing the request: RuntimeException

Thank you,
Any assistant will be very appreciated.

--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Uncaught Exception A software error was encountered that prevents normal operation

Peter Schober
* Alexandre Adao <[hidden email]> [2018-04-27 00:07]:
> Hello,  I am a novice on shibboleth. I am running on Windows Server 2016
> Standard. I have completed successfully the install and created the
> Metadata.  I configured the TestShib with no issues. However, when I
> actually do the test. I have the following error
> [...]
> No flow model 'authn/conditions' found

So you just installed the Shibboleth IDP as per the Shibboleth
documentation? Did you use someone else's documentation?
Did you configure anything beyond metadata and local authentcation?
-peter
--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Uncaught Exception A software error was encountered that prevents normal operation

Alexandre Adao
The issue was the idp.home defined on the Tomcat on Windows environment. I used the tomcat configuration tool to change the settings -Dipd.home from c:\shibboleth to c:/shibboleth

Thanks,
-Alex

> On Apr 27, 2018, at 4:21 AM, Peter Schober <[hidden email]> wrote:
>
> * Alexandre Adao <[hidden email]> [2018-04-27 00:07]:
>> Hello,  I am a novice on shibboleth. I am running on Windows Server 2016
>> Standard. I have completed successfully the install and created the
>> Metadata.  I configured the TestShib with no issues. However, when I
>> actually do the test. I have the following error
>> [...]
>> No flow model 'authn/conditions' found
>
> So you just installed the Shibboleth IDP as per the Shibboleth
> documentation? Did you use someone else's documentation?
> Did you configure anything beyond metadata and local authentcation?
> -peter
> --
> For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
> To unsubscribe from this list send an email to [hidden email]
--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]