Trouble test IdP

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Trouble test IdP

Tony Ennis


On the test page, I am supposed to type my IdP ID.  I have configured and uploaded my metadata file.  Is the entity ID referred to below the same entity ID that's in the metadata file, in the EntityDescriptor attribute? I rather thought that was my SP's name, not an IdP name.

Or perhaps it is the name of the metadata file I uploaded, that I was instructed not to forget?

Regardless of what I type, it tells me:  "TestShip Two / Unknown or Unusable Identity Provider. You have attempted to login using an IdP I've heard of..."

My SP is not running at all yet; I am trying to verify the IdP is functional.

Learning SAML, IdP, and SP is like sipping from a firehose! :-D



Rivera Group    
Tony Ennis
Chief Architect
[hidden email] | Rivera Group
O: 812.246.4055

Confidentiality Notice: This message and any attachments are for the sole use of the intended recipient(s), and may contain information considered confidential or privileged by the sending organization or trade secrets of the sending organization. This message does not authorize the intended recipient to disclose this information to any other party. Use, disclosure, or retention of any information in this message by anyone other than the intended user is strictly prohibited, unless otherwise authorized in writing. If you are not the intended recipient, please destroy all copies of this message.

--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Trouble test IdP

Peter Schober
* Tony Ennis <[hidden email]> [2018-07-09 18:01]:
> On the test page, I am supposed to type my IdP ID.  I have
> configured and uploaded my metadata file.  Is the entity ID referred
> to below the same entity ID that's in the metadata file, in the
> EntityDescriptor attribute? I rather thought that was my SP's name,
> not an IdP name.

Yes, the entityID in metadata describing your SP only contains your
SP's globaly unique name. Not any IDPs.

> Or perhaps it is the name of the metadata file I uploaded, that I
> was instructed not to forget?

No.

You're probably trying to access the wrong part of TestShib -- it has
both a SAML IDP and a SAML SP, and if you're being asked wher (at what
SAML IDP) you'd like to log in then you're accessing the SP part.
But you're not interested in the SP part of TestShib as you are the
(i.e., another) SP.

> My SP is not running at all yet; I am trying to verify the IdP is
> functional.

The way to do that is with a SAML SP. So either verify the TestShib
IDP using the TestShib SP, or set up your SP and use that one.
Or forget about verifying someone else's system and concentrate on
your own.

-peter
--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]