Shibboleth SP 2.5.4 Template Attribute Resolver: Unknown plugin type

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Shibboleth SP 2.5.4 Template Attribute Resolver: Unknown plugin type

Michael Nielsen

I am having trouble getting Shibd to see my Template attribute resolver.

 

No doubt it’s something obvious and I’ll be embarrassed but I just can’t see the problem.

 

Any help would be gratefully received.

 

 

Relevant parts of the shibboleth2.xml are:

 

  <OutOfProcess logger="shibd.logger">

    <Extensions>

      <Library path="plugins.so" fatal="false"/>  ß I have also tried the full path name, but received the same result.  No message about failing to load the plugins.so in the logs

    </Extensions>

  </OutOfProcess>

 

 

                <AttributeResolver type="Template" sources="clientIds" dest="clientId">

                        <Template>$clientIds</Template>

                </AttributeResolver>

 

My shibd.log:

2018-05-30 19:28:16 INFO Shibboleth.AttributeResolver.Chaining : building AttributeResolver of type (Template)...

2018-05-30 19:28:16 ERROR Shibboleth.AttributeResolver.Chaining : caught exception processing embedded AttributeResolver element: Unknown plugin type.

 


--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: Shibboleth SP 2.5.4 Template Attribute Resolver: Unknown plugin type

Cantor, Scott E.
>       <Library path="plugins.so" fatal="false"/>  <-- I have also tried the full path
> name, but received the same result.  No message about failing to load the
> plugins.so in the logs

Basically impossible, that is the error, so you either didn't restart it or that isn't in the actual configuuration. If you're going to depend on it working you should flip the fatal flag anyway.

-- Scott


--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

RE: RE: Shibboleth SP 2.5.4 Template Attribute Resolver: Unknown plugin type

Michael Nielsen
Ok, thank you, Scott.

I *think* what was happening is that I was relying on the dynamic reload of the shibboleth2.xml instead of fully restarting the shibd.

Thanks again for taking the time to respond.

-----Original Message-----
From: users <[hidden email]> On Behalf Of Cantor, Scott
Sent: Wednesday, May 30, 2018 4:35 PM
To: Shib Users <[hidden email]>
Subject: ADV: RE: Shibboleth SP 2.5.4 Template Attribute Resolver: Unknown plugin type

>       <Library path="plugins.so" fatal="false"/>  <-- I have also
> tried the full path name, but received the same result.  No message
> about failing to load the plugins.so in the logs

Basically impossible, that is the error, so you either didn't restart it or that isn't in the actual configuuration. If you're going to depend on it working you should flip the fatal flag anyway.

-- Scott


--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]


--
For Consortium Member technical support, see https://wiki.shibboleth.net/confluence/x/coFAAg
To unsubscribe from this list send an email to [hidden email]