Regression identified in Service Provider library, new version pushed

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Regression identified in Service Provider library, new version pushed

Cantor, Scott E.
A fix unrelated to the security issue we just released a patch for was erroneous and unfortunately caused a regression in the "traditional" metadata refresh code most people are relying on. An updated xmltooling library, V1.6.2, has been released to undo the change that caused the regression, and updated SP 2.6.1 packages are available for Windows and Linux with the fixed library.

The only caveat for anybody that's already applied the 2.6.1 updates is that a Linux yum update won't restart shibd, so that has to be done manually after updating the xmltooling package to restore the metadata refresh behavior.

Going straight from < 2.6.1 to the latest packages works normally without any additional care.

We apologize for the inconvenience, we'll be more conservative about including unrelated fixes in the future when it comes to getting important patches out.

-- Scott


--
To unsubscribe from this list send an email to [hidden email]