Message did not meet security requirements

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Message did not meet security requirements

sai_code
HI,

 I am using our application to login to different application throught
different idp's using ukfederation metadata for the institutes who hav
registerd in uk federation .

Till now for one institute this works file..once that institute was upgraded
to shib 2 from shib 1
and they got error message as below
------------------------------------------------------------------------------
----------------------------------
"ERROR

An error occurred while processing your request. Please contact your helpdesk
or user ID office for assistance.

This service requires cookies. Please ensure that they are enabled and try
your going back to your desired resource and trying to login again.

Use of your browser's back button may cause specific errors that can be
resolved by going back to your desired resource and trying to login again.
Error Message: Message did not meet security requirements"

------------------------------------------------------------------------------
----------------------------------

I just checked that this metadata is file in ukfederation url and check log
files in our service provider.

This error occur for the "University of Gloucestershire" with idp url
          "https://idp1.glos.ac.uk/entity"

Can any one tell me the solution for this please?


Thanks
Sai
Reply | Threaded
Open this post in threaded view
|

Re: Message did not meet security requirements

Shen Hongzhou
Hi Sai,
Check your machine's system time, you should keep all of your machines in time synchronization.

Shen

2010/7/1 <[hidden email]>
HI,

 I am using our application to login to different application throught
different idp's using ukfederation metadata for the institutes who hav
registerd in uk federation .

Till now for one institute this works file..once that institute was upgraded
to shib 2 from shib 1
and they got error message as below
------------------------------------------------------------------------------
----------------------------------
"ERROR

An error occurred while processing your request. Please contact your helpdesk
or user ID office for assistance.

This service requires cookies. Please ensure that they are enabled and try
your going back to your desired resource and trying to login again.

Use of your browser's back button may cause specific errors that can be
resolved by going back to your desired resource and trying to login again.
Error Message: Message did not meet security requirements"

------------------------------------------------------------------------------
----------------------------------

I just checked that this metadata is file in ukfederation url and check log
files in our service provider.

This error occur for the "University of Gloucestershire" with idp url
         "https://idp1.glos.ac.uk/entity"

Can any one tell me the solution for this please?


Thanks
Sai

Reply | Threaded
Open this post in threaded view
|

Re: Re: [Shib-Users] Message did not meet security requirements

sai_code
u mean to check application installed system time (server machine)

Can u detailed about this pelase?

Thanks
Sai
Reply | Threaded
Open this post in threaded view
|

Re: Message did not meet security requirements

Peter Schober
In reply to this post by sai_code
Sai,

Don't just reply to any email from the list unless you intend to
contribute to that specific thread. Instead, compose a new email to
the list address.
This messes up less capable mail user agents and mail archiving
software.

* [hidden email] <[hidden email]> [2010-07-01 08:22]:
> and they got error message as below

The error message listed in the subject of your mail is the second
from the top at
https://spaces.internet2.edu/display/SHIB2/NativeSPTroubleshootingCommonErrors

(This page is listed from
https://spaces.internet2.edu/display/SHIB2/Troubleshooting
which in turn is listed in the start page of the shib wiki, which is
the official documentation.)

Note that there is also UK Federation specific support available at
http://www.ukfederation.org.uk/content/Documents/FedSupport
-peter
Reply | Threaded
Open this post in threaded view
|

Re: Re: [Shib-Users] Message did not meet security requirements

Shen Hongzhou
In reply to this post by sai_code
Yes, you should make sure that all the machines that run IDP, SP and DS have a same system time.
I have met the same problem with you, and I resolved it by synchronizing all the machines' system time.
Just try it.

2010/7/1 <[hidden email]>
u mean to check application installed system time (server machine)

Can u detailed about this pelase?

Thanks
Sai