Apache Basic Auth with Shibboleth

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Apache Basic Auth with Shibboleth

cahillchaz
I have an Apache Web server with the Service Provider Installed.  I need Basic Auth on several of the URL's that are being protected.  Others are using Shibboleth and working.  Seems like Mod_shib is jumping in during my Apache Basic Auth request and causing it to fail.  

Can you tell me how to turn it off.  Log signature below.

[Tue Feb 09 17:30:53.823869 2016] [authnz_ldap:debug] [pid 40:tid 140659752183552] mod_authnz_ldap.c(516): [client 3.101.106.210:34729] AH01691: auth_ldap authenticate: using URL ldap://xxxxx/xxxxxx?uid?sub?(objectClass=*)
[Tue Feb 09 17:30:53.823956 2016] [authnz_ldap:debug] [pid 40:tid 140659752183552] mod_authnz_ldap.c(613): [client 3.101.106.210:34729] AH01697: auth_ldap authenticate: accepting 22xxxxxxx
[Tue Feb 09 17:30:53.823978 2016] [mod_shib:debug] [pid 40:tid 140659752183552] mod_shib.cpp(1584): [client 3.101.106.210:34729] shib_base_check_authz found uninitialized request object
[Tue Feb 09 17:30:53.824002 2016] [authz_core:debug] [pid 40:tid 140659752183552] mod_authz_core.c(809): [client 3.101.106.210:34729] AH01626: authorization result of Require valid-user : denied (no authenticated user yet)
[Tue Feb 09 17:30:53.824010 2016] [authz_core:debug] [pid 40:tid 140659752183552] mod_authz_core.c(809): [client 3.101.106.210:34729] AH01626: authorization result of <RequireAny>: denied (no authenticated user yet)
[Tue Feb 09 17:30:53.824015 2016] [authz_core:error] [pid 40:tid 140659752183552] [client 3.101.106.210:34729] AH01629: authorization failure (no authenticated